You can use it for all Samsung devices, but I have only tested it on Galaxy Tab S. It requires .NET Framework 3.5 (Microsoft Visual C++ 2008 Redistributable Package (x86) and Microsoft Visual C++ 2010 Redistributable Package (x86) installed)
If you run it via command line, you can use it to just decrypt .zip.enc2 and .zip.enc4 files

SamFirm_v0.3.1   Download


SamFirm_v0.3.2  Download


SamFirm_v0.3.3  Download


SamFirm_v0.3.4  Download


SamFirm_v0.3.5  Download